Back to overview
Maintenance
Slow DNS server
May 18, 2026 at 2:42pm UTC
–
May 19, 2026 at 2:40pm UTC
Affected services
CORE.GLAND.AS213929.ch
Resolved
May 19, 2026 at 2:40pm UTC
Maintenance ended
Affected services
Created
May 18, 2026 at 2:42pm UTC
Our DNS server, as well as the management interfaces for your services, are currently experiencing disruption due to a DNS issue; you may also experience slow DNS response times on your services.
We apologise for any inconvenience caused.
The issue has been resolved: 14:40, 19 May 2026
Affected services